
 

File Management with Windows 
 

 

What is File Management?  

Computer programs and data, including things that you have created yourself (for instance,  

an essay written using a word processing program) are all stored as files. A file is simply a  

collection of data stored in a way that the computer can read it. Every command you give  

to a computer involves using some sort of file. When you start up a word processing  

package again you are running a program, and you will need to be able to save the  

information that you input into a file. Subsequently you may wish to make further  

changes so you need to know where to find the saved file, and perhaps you’ll want to  

print it out or copy it from a hard disc onto a USB pen drive or CD disc. There are many 

ways of performing these basic file management tasks on Windows, but in this section we  

are going to introduce two of them, namely using My Computer and Windows  

Explorer (simply Explorer, from here on).  

 

Good management of files underlies all safe IT prac tice. Your files and data  

represent an investment of time and thought, and you should ensure that you look  

after them carefully.  

 
Seeing what is on your Computer  

Double-click the My Computer  icon on the desktop.  A window appears showing  

various icons, which include the drive letters for disc drives where files can be stored.  

A drive is a device for storing and reading data. It contains a disc or discs (which  

may or may not be removable) on which the data is stored in the form of files.  

Usually drive C: is the computer’s in-built hard disc and D: a DVD/CD-Rom drive. Drive E: 

is usually available for other portable storage, such as USB pen drives.  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If you are using a computer that is part of a cluster, you may also see an icon like  

this, indicating a networked drive. This means the physical drive has a different location 

from the computer that accesses it. This is also identified by a letter; on university campus 

computers, this is often H.  

 

 

 



 

 

 

To see the files on a drive, double click on its icon.  
 

 

This window shows the contents of the hard disc (or C: drive), and each different type  

of icon represents a different type of file.  

 

The most common icon you see looks like a paper document wallet, and this  

represents a folder into which can go files and other folders. In this example the  

folder is called IT Course. To see the contents of a folder, double click on its icon.  

 

Here we can see that there are three files stored within the  

IT Course folder, and from the icons we can tell that one is  

a word processed document created with Word, one is a  

spreadsheet file created with Excel and the other a PDF  

document. Later on we’ll expand on the names given to  

these files.  

 

 
 

Note the buttons at the top of these windows. (If you don’t see these at first, select  

ViewToolbarsStandard Buttons). The Back button allows you to return to  

the previous view – for instance from “IT Course” back to the main C:drive window.  

The Forward button takes you forward, so you can switch back and forth between  

two areas. The Up button takes you up one level – this is not the same as Back 

because if you had been looking at several folders at one level, Back would not  

immediately take you up a level.  

 

If you are not sure where a file is, clicking the Search button brings up a window into which 

you can enter details of a file and search for it. Clicking the Folders button gives you a view 

of all the currently available drives/folders on the left hand side of the screen, which allows 

you to reach files more quickly.  

 

Drives that exist physically on, or 

attached to, your computer 

Drives that your computer 

accesses via network connections 



The next button is the Views button, which allows you to view folders/files in different 

levels of detail from a simple icon to full file size, type and date information. After the 

Views button are three buttons (which are only active if a file is selected) that allow you to 

Delete, Move or Copy a file. The next button is the Undo button but remember this will not 

be effective on networked drives.  

 

Note: some of these buttons may appear in a slightly different order on your computer. If  

icons just described are missing, select ViewToolbarsCustomise and choose  

the ones you want to add.  

 

Explorer works in much the same way as My Computer. To start Explorer, position  

the mouse over the Start button on the taskbar, and click the right mouse button –  

note that it is the right button and not the usual left one. From the menu that appears,  

choose Explore with the left mouse button.  You will see that the same information  

appears, but its default view is with the split window, with the left hand side showing  

folders in the form of a hierarchy, or “tree”. 

 
The Selected Folder Status Bar Contents of the selected Folder 

 

On the left side of the window, disc drives and folders appear. As you select items  

from this side, you will see that the right side of the windows expands on the contents  

of the folder, or drive, highlighted. These contents may be sub-folders or files, or  

both. As you become familiar with using a computer you will probably develop a  

preference for using either Explorer or My Computer. They can both be used to  

achieve the same end result. Note that you can change how the My Computer  and  

Explorer windows will display files and folders by selecting Folder Options from the  

Tools menu.  
 

In Windows a My Documents icon appears on the desktop. On your home  

computer, this links directly to a folder on the computer’s hard drive and is your 



 

default storage location when you save any file. This folder also can be seen when  

you open Explorer or My Computer. On university campus PCs this folder will exist  

on your network storage space (H: drive), so that you can access it from any campus  

computer.  

 
Portable Storage Media  

PCs allow you to save data to different types of portable storage medium, which allow  

you to transfer files between computers which are not connected by a network: e.g.  

transfer files between your home computer and one on campus. Some PCs in the university 

clusters allow you to write to an R/W CD or DVD. CDs can hold as much as 750 megabytes 

of data and DVDs about 4.5 Gigabytes of data.  
 

Another storage medium is the USB Key, which contains a flash memory chip that can hold 

from 1 Gigabytes of data up to 256 Gigabytes. These can be used with any PC that has a 

USB port. 
 

Read/Write CD  

You can save files to a writeable CD by copying using My Computer or Explorer. To begin the 

process, insert your CD into the D: drive and open My Computer or Explorer to access the 

files you want to copy.  Select and Copy the files and then click on the My 

Computer link to access the D: drive (or other drive if you have more than one 

CD/DVD drive.  You should now see a link named Write these files to CD . 

 

 
 

Paste the files onto the D: drive.  To complete the write process, click on the Write these 

files to CD link and the CD Writing Wizard will open. 

 



 
 

Follow the Wizard’s instructions to complete writing to your CD.  When finished, don’t 

forget to remove the CD from the PC – especially if you’re using a Campus PC! 
 

USB Keys  

A USB Key (or Pen Drive), which is a shaped like a flattened pen is attached to the USB port of a 

PC, after which it can be treated like any other drive on your PC. You can copy files to or from it 

by simple drag and drop or by using copy and paste in My Computer  or Explorer. When you 

have finished using the USB Key, make sure to click on the Safely remove USB Mass 

Storage Device option on the Taskbar before removing it.  

 
Naming Files and Folders  

Files are stored in areas called drives whose location the computer recognises. You already have 

seen that drives are given letters of the alphabet as identifiers: e.g.,  drive D: for the CD/DVD disc 

drive. Files on drives are usually grouped into folders, which can be nested in a hierarchical 

arrangement, so that top-level folders can contain sub-folders, and so on down to individual files. 

 

 

 

 

 

 

Files and folders must be given names when you create them. The structure for the name of a 

file is different to that of a folder, in that it has as part of the name a three-character 

extension, separated from the filename by a dot (full stop). Extensions are used to help 

recognise the file type (i.e. the sort of data which the file contains); if the program, which you 

are using, cannot recognise a file it will not be able to use the data in it. Files with an 

extension .exe are usually programs, which you can run, whilst those with .doc are usually 

documents created by MS Word .   
 

There are many file types and corresponding extensions. For instance, there are many 

different graphics file types, and some of the most common graphics file extensions are: 
 

.bmp  Windows bitmap images 

.gif or jpg Common formats for images on Web pages 

.wmf Windows metafile (a common format for clipart) 

 

 



Organising your files  

It is up to you to decide how to organise your files, just as you would do if you were  

putting pieces of paper into files, which are stored in a filing cabinet. You could elect  

to keep all your word processing files in one place, or store work (of all file types) for  

a particular project in an appropriately named folder.  

 

When using floppy discs it is unlikely that you will have a complex structure of  

nested folders, indeed you may not bother to store files in a folder at all. With a hard  

disc or network storage area, the situation will be different, because you are likely to  

have a lot of disparate material, which needs to be organised or you will lose track of  

it. Practise looking at what’s on your hard disc s o that you get used to clicking on  

folders, at the level of nesting you want, to see what’s inside them, and get a feel for  

the overall organisation of files on the disc. 

 
Setting up and Deleting a Folder 

To create a new folder:  
a. Double click the disc drive or existing folder that you wish to put the new folder  

into. Be sure about this, as it is at this point that most errors occur  

b.  Select New from the File menu, and then click Folder.  
c.  A new folder icon appears with the text New Folder highlighted underneath.  
d.  Replace this text by typing in the name that you wish to allocate to it. 

e.  Check that it is where you intended it to be. If not, delete it and start again. 
 

To delete a folder:  

a. Check there are no files, which you wish to keep, in the folder then highlight it.  

b. If there are any files you wish to keep, and you still wish to delete the folder,  

move these files to another folder.  

c. Highlight the folder you want to delete then select Delete from the File menu  

(or click the delete button on the toolbar).  
d. Confirm that you want the folder deleted by clicking on Yes. This moves the  

folder, and any contents, to the Recycle Bin.  

 

Remember that the Recycle Bin is a holding place for deleted files and that these  

files are not actually deleted from the computer until you have told it to empty the  

Recycle Bin. (To do this double-click the Recycle Bin icon, and select Empty  

Recycle Bin from the File Menu.)  

 

This means that you can get back files that you  

have accidentally deleted. However if you need to free up disc space the Recycle Bin  

should be cleared out from time to time.  

 
Examining and Running Files 

The way in which the files and folders are presented to you, and the amount of  

information given about them, can be changed. To do this, select the View menu and  

choose from Large Icons, Small Icons, List or Details. The Details option will  

display the name, size, type and the date that the file was last modified.  

 

 
 

 

Clicking on any of these headings (at the top of 
the section of the window displaying the 
folders/files) will arrange them in a suitable order – 
e.g. clicking on Name orders alphabetically, on 

Date Modified by date, etc.  



Knowing the size of the file tells you whether you can fit it onto a floppy disc. Knowing 

when it was last used helps you identify the latest version of a document of which you may 

have multiple copies as backups, all with rather similar names. You can also change the 

order in which files are displayed by selecting Arrange Icons from the View menu (or by 

clicking on the file details column headings). 
 

A file can be run straight from the My Computer  or Explorer 

window. You can do this by double-clicking on it or by right- 

clicking and selecting Open. If the file is a program (usually  

with an .exe extension) it will run. If it is a data file, such as a  

word processing document, it will open the application it  

needs, then open itself. This will only happen successfully if  

the application is already on your computer. Thus, double- 

clicking on a word processing file will only open the file if  

you already have the word processing software installed.  
 

Some files will already be pre-set to open this way, but sometimes you may wish to open 

other file types. To do this, first click on the file you wish to open, then select Open With 

from the File menu and select the appropriate application from the list displayed. You should 

make sure the Always use this program to open this file box is ticked if you expect to be 

using this file type regularly. 

 
Copying, Moving and Deleting Files  

To copy a file:  

a. Highlight the file you want to copy. 

b. Select Copy to Folder from the Edit menu. A window will open displaying the folders on 

your computer. 

c. Choose the folder where you want to place the file. If you want to copy a file to another 

disc drive you can choose this in this window too.  

d. You also have the option of creating a new folder to store the copy: simply click the 

Make New Folder button.  

e. Click the OK button to Copy the file.  
 

You can Move files in a similar fashion by choosing Move to Folder from the Edit menu.  
 

Once you are used to using My Computer  or Explorer you can copy and move files by  

opening windows for the discs or folders involved. By repositioning the windows you can 

then drag file or folder icons from one window to the other. Practise doing this, as it is easy 

to make mistakes and delete files/items that you didn’t want to lose. Note that, when you 

drag between folders in the same drive, the file moves and is no longer in the original folder. 

When you drag between folders in different drives the file will be copied and will then exist 

in both folders.  
 

If you copy files, think up suitable names for the copies, so that you can tell them apart 

easily. But don’t change extensions or the applica tion with which the file was created will 

not be able to read it any more. To rename a file, select it using My Computer  or Explorer 

and choose Rename from the File menu. The file name will be highlighted and you simply 

type over it with the new name you want to give it. Remember to keep the same  

extension for the file name!  
 

 

 

 

 

 



To delete a file, select it by clicking on its name and then choose Delete from  

The File menu or click on the Delete button. If you mistakenly delete a file,  

you can retrieve it by choosing Undo Delete from the Edit menu. Alternatively, you  

can open the Recycle Bin and, select the file you wish to retrieve, then click on the  

Restore button. 

 
Backing up Files 

Backing up files is very important. Even though computers nowadays are very reliable, 

accidents can occur - and human error is always possible. You should always keep a backup 

of any file you create. When working on a file, you should back up at regular intervals so 

that, if anything goes wrong, you will only have lost a few changes.  
 

At university, if you store files on a networked file server, backups will have been arranged 

by the cluster managers.  So if you do accidentally delete files they may be able to retrieve 

copies from routine backup tapes.  

 

You can’t depend totally on the network back up, however.  Back-ups are made regularly 

throughout the day but there might be a system failure just before a back-up is due and you 

could easily lose as much as an hour’s work – if you haven’t been making your own regular 

backups.  Make more than one backup of files that are important, and keep them in different 

places.  And, if you back up to portable storage (e.g. disc or USB pen drive) don’t forget to 

remove it from the PC and put it in safe place. 


