
Spreadsheets with Excel 
 
1. What is a Spreadsheet? 
 

Spreadsheets allow the automation of the entering of numbers, typically budgets and 

statistics.  They also allow “what if” questions to be asked. In effect, the spreadsheet is a tool 

for simulation, and can be used in this way in all sorts of non-business applications, e.g. for 

environmental simulation. They can also be used for organising data, producing simple 

collections of records which can be sorted and searched. 

 

2. Using Excel 
 

To start Excel, click on the Start button on the taskbar and from Programs select Microsoft 

Excel. To close Excel once you have finished working with it, select Exit, from the File 

menu. Before closing, ensure that all your work is properly saved.   
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A spreadsheet allows data, both text and numbers, to be 

laid out on a grid made up of individual cells ordered 

into rows and columns.  Each cell can then be 

identified by its column and row number: thus cell C5 

is in column C and row 5.  

 

 

 



Spreadsheets also allow cells to be linked to one another.  Changing a value in one cell will 

change the values in cells which have been linked to it. Thus if cell D6 is always twice the 

value of cell A3, then changing the value of A3 from 4 to 7 will lead to the value in D6 

changing from 8 to 14. Cells may be linked to more than one other cell; so one cell may 

contain the sum of a whole row or column of cells. In this respect spreadsheets are very 

useful for the manipulation of numeric data. 

 

3. Entering Data in a Cell 
 

As information is typed in a cell, it appears first at 

the top of the screen in the Formula Bar. Having 

ensured that the entry is correct, press Return, 

which will move to the next row down or Tab, 

which will move to the next column across.  

Alternatively, you can move to another cell using the cursor keys or the mouse. 

 

The information can be confirmed by clicking the  on the Formula bar, or removed by 

clicking the X on the formula bar. (These appear when you start typing in the cell). 

It is easiest to enter the information in a logical way, either across each row or down each 

column. 

 

If data (typed or resulting from a calculation) does not fit into a cell, 

one of two things will happen. If the data is purely mathematical, then 

it will be displayed in scientific notation – a compressed format. (For 

instance, 67449037 would be shown as 6E+07). If the data represents 

something, e.g. currency, a series of hash marks will be displayed.  Do not worry: the data is 

not lost; this just signifies that the data cannot be displayed properly unless you change the 

cell size. 

 

You can do this by placing the cursor at the edge of the column heading 

(where it will change to a cross) then click and drag with the mouse to 

make the column wider. 

 

4. Editing Data 
 
Before editing, you must select the cells to be edited, in one of the following ways: 

 Click anywhere in a cell to select it – drag to select more than one cell. 

 Click on the row number at the left of the window to select a whole row. 

 Click and drag over several row numbers to select more than one row. 

 For columns, click on the column letter at the top of the window. 

 Click and drag to select more than one column. 

 To select non-adjacent columns or rows press Ctrl and click in the row numbers or 

column letters required. 

 To deselect, or to start again, click once anywhere on the worksheet. 

 

To replace a cell’s contents, select the cell, type the new data and press Return or Tab. 

 

To edit a cell’s contents, select the cell then insert the cursor in the appropriate position in the 

Formula bar.  Backspace to delete or type to add new data. 

 



To delete data from a cell, right-click on the cell to display the 

drop down menu.  Clicking the Clear Contents option will 

remove the data, but not the formatting, and leave the cells 

intact. 

If you click the Delete option in the right-click menu, a 

Delete dialog box will be displayed. With the Delete option, 

you will physically remove rows/columns from the worksheet.  

Select your option and click OK. 

 

Be careful how you use the options 

Clear and Delete on the Edit menu. 

Clear empties the cell contents 

without deleting the actual cell, 

whereas with Delete the cell will be 

removed. 

 

Inserting a blank row can be carried out by selecting the row, which you want to be moved 

down, then selecting Insert Rows from the Cells group on the Home tab. To insert a 

column, select the column to be moved to the right, then select Insert 

Columns the same way. 

 

The last action can also be undone or redone. Click the Undo or Redo button 

on the Excel Quick Access Toolbar or use Ctrl + Z to undo, F4 to repeat. 

 

5. Loading Data from a File 
 

Choose Open from the File tab. Select the drive and directory where your file is 

located. Excel files will have the extension .xlsx. If the Workbook you open has 

several sheets of data, select the sheet you want to work with by clicking the 

appropriate Sheet tab (at the bottom of the Excel window) with the mouse. If you 

simply want to create a new file from scratch, select New on the File tab.  
 

6. Saving data to a File 
 

Click on the Disc icon on the 

Excel Quick Access Toolbar or use Ctrl + S 

or choose Save from the File tab.  The first 

time you save a file the Save As dialog box 

appears. 

  

Choose the drive and folder you want to save 

to as with other applications. Note that in 

Excel, a Workbook is the file in which you 

work and store information, and a Workbook 

can contain many worksheets (spreadsheets). 

 

This way a series of related spreadsheets 

and/or charts can be kept together as one file. 

 



There are usually 3 sheets to start with which can be added to if required.  You can add a new 

worksheet by clicking on the New Tab icon. A new sheet appears, numbered in sequence. 

 

 
 

You can select a sheet to work in by clicking on its tab, at the bottom of the window.  You 

may wish to give worksheets individual names: right click with the mouse and choose 

Rename from the menu which appears. 

 

If you are working on a Workbook, save it regularly, and back up your file regularly, so that 

you can revert to a previously saved version should you mess something up. 

 

7. Copying and Moving Data 
 

To leave the data at the original position and copy it somewhere else 

select it, then click the Copy button in the Clipboard group on the 

Home tab  (or press Ctrl + C).  The cells will now have a flashing 

border around them.  

 

To cut text from one place in the worksheet and paste it to another location, select the text 

you want to cut then click on the Cut button (or press Ctrl + X). The cells will again have a 

flashing border around them.  

 

To paste the data in both cases, select the cell where you want the text to appear and click on 

the Paste button or press Ctrl + V.  When pasting the data you need only select the starting 

cell and all the cells required will be filled. Be careful when pasting to ensure that there is 

room for all the data to fit or this action will over-write other data. You can paste repeatedly 

from a copy, but only once from a cut. When you paste from a cut, the flashing border will 

disappear. To remove the flashing border after pasting from a copy, press the Esc or Enter 

key or double click on any cell. 

 
8. Formatting Cells 
 

Select the cells that you want to format in the way described above. Format the data by 

choosing Cells from the Format menu, and selecting the format required in the Format Cells 

dialog box. Many of the choices here are the same as in Word: for instance you can change 

the text font, alignment, add a border, or background shading. Choose the type of formatting 

you want to use from the options on the Home tab. You will then be presented with menus, 

and buttons with which you can select the formatting you require. 

 

 
 

 



Specific to Excel is the wide range of number formats that 

can be applied to cells. There are several different categories 

of number formatting available: you can format for currency, 

time, date, fraction and even scientific numbering. For 

instance you can select the category Currency and then you 

can choose decimal places and a currency symbol. You can 

also custom the numbering to suit your specific needs.  

 

Titles can be centred across a number of cells.  Highlight the cells on 

the same row as the title (including the title cell) across which you want 

it to be centred.  

 

Then, from the Home tab on the Ribbon, on the Alignment group, you 

can press the Merge and Centre button.  

 

The default cell is often not wide or high 

enough for the information to be entered, 

especially for row headings down the left of 

the screen. You can, however, change the size of a column or row.  Point at the line on the 

right-hand side of the column whose width has to be changed. The mouse pointer will 

change. Click and drag to the right till the column is the required width. The height of a row 

can be changed in a similar fashion. 

 

9. Sorting Data 
 

Spreadsheet data can be reordered rapidly and easily.  Data is usually sorted alphabetically or 

numerically in either ascending or descending order.  You can sort the data by using the 

options in the Sort & Filter menu in the Editing group under the Home tab.  

 
 

You can use one of the AZ/ZA Sort options; but first you must 

select a cell in the column you wish to sort on.  These will only sort 

on one column: to sort on more than one column you must use the 

Custom Sort option.   

 

Before you sort, you must select a cell within the data and this will 

be expanded to select all the data when you choose Sort.  In the 

Custom Sort dialog box (see image next page) select which column 

or columns you wish the data sorted upon, then click OK.  

 



 
 

You can sort on more than one heading. That is to sort within the sort. For instance a 

collection of data about a national company includes agents in each region. By sorting on 

Region and then on Agent, the data can be ordered to show each region in alphabetical order 

and the agents ordered alphabetically within each region. 

 

Note: if the data in a column is text you will sort A to Z or Z to A; if it is numerical you will 

sort Largest to Smallest or Smallest to Largest. 

 
10. Calculating with Formulae 
 
A spreadsheet can enable you to add up columns and rows of numbers quickly and easily and 

to apply mathematical formulae to spreadsheet cells. You can type in a formula (always 

beginning with the “=” sign) to perform calculations using various mathematical operators, 

e.g. 

 

+ add - subtract * multiply / divide 

 

When calculating the result of a formula, Excel will always use these operators in a specific 

order:  

1. Division or Multiplication  

2. Addition or Subtraction.  

    Brackets can be used to alter this normal order, if required. For example: 
 

=2+2*2 would give an answer of 6, not 8 as you might expect. This is because the 

multiplication comes before the addition, so 2*2 is done first, then 2 is added to the result. 

=(2+2)*2 would give the answer 8, since whatever is in the brackets is calculated first. 

 

However, you will not usually be working solely with numbers, but will use cell references to 

perform calculations on the data you enter. Simple formulae may involve referencing data 

from only two cells. For example, to add the contents of cells A1 and A2 and place the result 

in A3, position the cell pointer in A3 and type =A1+A2. 

 

Remember, you must type the “=” sign. The result of the calculation appears in the cell, but 

the formula appears in the Formula bar. If either A1 or A2 changed, A3 would 

automatically change to reflect the new result of the formula. 

 



11. Functions 
 
Excel has statistical, mathematical, financial, string and logical functions, which can be 

applied to your data.  Select the Formulas tab to see Function Library group.  

 

This has a selection of drop-down menus 

menus. There is a drop-down menu for each 

choice of function category, e.g. Date & 

Time, Financial, Math & Trig, Statistical, 

Logical, etc.  

 

The fx (Insert Function) option to the left opens a dialog box which gives access to the all 

functions available; you can search or choose a category. 

 

For example, under Statistical you can find: 

MAX is used to find the maximum value of a range of cells, e.g. =MAX(A1:A10) 

MIN is used to find the minimum value of a range of cells, e.g. =MIN(A1:A10) 

AVERAGE is used to find the average of values in a range of cells, e.g. 

=AVERAGE(A1:A10) 

TODAY can be used to insert today’s date into the current cell, e.g. =TODAY() 

 

One very useful function (addition) is also available by using the AutoSum button. 

Select a cell to contain the total (i.e. at the bottom of the cells you are adding) and click the 

AutoSum button (Σ). The computer will select a range of cells to be added. 

The selection will be shown enclosed in dotted lines. You can alter this selection by dragging 

with the mouse. Press Enter to complete the function action. 

 

In Excel the AutoSum button gives quick access to a menu of basic 

functions when the little down-arrow on this button is clicked. The 

options are: Sum, Average, Count, Max and Min.  Selecting More 

Functions opens the Insert Function window. 

 
12. Cell Reference 
 

As explained above, one cell may hold a formula, which performs a calculation on data 

contained in one or more other cells. The same calculation can be performed repeatedly, on 

different sets of data. This can be done by copying and pasting the cell containing the formula 

for the calculation into other cells. Excel will automatically change the formula so that it will 

refer to the appropriate data.  So if, for instance, you entered a formula to multiply the figures 

in cells A1 and B1 together, you could then do the same to the figures in the cells directly 

below by copying and pasting the formula.   

 

 
 

Thus the formula in cell D1 (above) will multiply the number in cell A1 by the number in B1. 

If any of these numbers change, the result in cell D1 will also change. When the formula in 

=A1*B1 

=A2*B2 

=A3*B3 
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D1 is copied into cells D2 and D3, the formula in each cell will be changed to refer to cells 

on the same column as in the original formula but on different rows, depending on the cells 

copied to. 

 

This situation is known as Relative Referencing, as cells referenced by the formula change 

in relation to their position in a column or row. You must make sure that all the rows (or 

columns) are arranged in a similar way. Each copy of the formula will automatically change 

its cell reference so that it refers to and uses the appropriate data. 

 

However, the situation often arises when a specific piece of data used in a calculation must 

always remain the same. For instance if you needed the same constant to be used by several 

formulae – such as a VAT rate. The rate could be entered in a cell, which could then be 

referenced by the formulae that needed to make use of the rate.  (The advantage of doing this 

is that if you want to change the VAT rate later, you need only change one cell and all the 

formulae will reflect this change). 

 

To ensure that the same cell is referenced by all the formulae, which require it, a dollar sign 

($) is placed in front of both the row and column references in the formulae which reference 

the cell containing the necessary data. This means that no matter what cell the formula is 

placed or copied into, it will always reference the same cell for the data. 

 

 
 

Thus you would make use of the data in cell B6 by using the reference $B$6, to ensure that 

the same data was always used. This is known as Absolute Referencing. If the dollar sign is 

placed before a row reference number, but not a column reference letter, or vice-versa, then 

the absolute referencing only limits the reference to a specific row or column and not to a 

specific cell. 

 
13. Freezing Panes 
 
If you are scrolling through a list of data 

arranged in columns or rows, it is easy to lose 

track of what data in any particular cell refers 

to.  

 

A solution to this problem is to freeze the cells in the row or column containing the headings. 

When this is done, the headings will remain static while the data scrolls past them; this way 

you will always see what headings refer to any data. To freeze panes, first select the row or 

column just after the line containing the headings, then select Freeze Panes from the 

Window group on the View tab. 

 
 
 
 

=C2+(C2/100*$B$6) 

=C3+(C3/100*$B$6) 

=C4+(C4/100*$B$6) 



14. Charts 
 

Basics: Charts enable you to show data in a graphic format. A chart can be created on a 

worksheet so that it appears alongside the data it represents, or as a separate worksheet.   To 

create a chart using a keyboard shortcut, select the data to be charted and press F11.  

Creating a chart this way adds a new worksheet to the workbook called Chart 1.  

 

 
 

The chart that is produced uses all the current defaults. If you haven’t changed any of the 

default settings, the chart you will get by pressing F11 is a Column Cluster Chart.  

 

If this isn’t the type of chart you want to produce then you need to change the 

default chart type. To do this, click the Change Chart Type button. (When 

you press F11, the new sheet containing the chart opens with Chart Tools 

active – as they are whenever you select a chart).   

 

More on Charts 

There are two other methods of creating charts, giving 

immediate access to a range of different chart types.  

 

Select the data to be charted, including row or column 

headings to be used as labels, and then access the Charts 

group under the Insert tab. 

 

When you have made your selection of the chart options 

(selecting first general chart type, then subtype from the 

chosen menu), the chart automatically appears in the same 

worksheet as the selected data.  

 

At the same time new chart options appear on the Ribbon.   

 

 
 

These options affect the way your charts will appear – so you should choose carefully as 

good choices will make it easier for others to understand what your chart represents.  
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If you prefer the more traditional style of 

chart selection, use the Insert Chart dialog 

box. Note: unlike the earlier version this 

dialog box does not allow you to format the 

layout of charts you choose nor add labels, 

legends or gridlines. However Chart Tools 

has options that allow you to do this (see 

below). 

 

All the different chart types (e.g. Bar, Pie, 

Column, Scatter, etc.) available on the 

Ribbon are seen in the left-hand pane with 

the sub-types in the main pane accessible for selection. 

 

The Chart Layouts option (under the Design tab) 

allows you to choose different chart designs, for 

instance, below you see one which displays the data in 

a table below the chart. 

 

The Chart Styles option under the Design tab 

lets you to choose from a variety of colour 

styles. 

 

Clicking once on a chart selects it and places sizing handles around it so that you can 

change its location or size on the screen, or delete it if you wish to replace it. You 

can also move a chart to a separate worksheet via the Move Chart button. 

 

To add extra data to a chart – or change the data completely –select the chart and then 

click the Select Data button in the Data group. This can be useful – e.g. if you create 

a chart one year, when new data is added for the following year you can select it 

(using Ctrl key if necessary) to show a comparison for the two years.   

 

 
 

The Select Data Source dialog box opens, which displays your selections. You can make a 

selection by typing in the cell references the Chart data range box or by dragging over the 

data with the mouse. 



Chart Layout and Format 

You will often want to edit the chart format and layout (e.g. grid lines, data labels) and 

change the format.  Of these the Layout is most important as it is this which (used properly) 

ensures your chart can be understood and interpreted correctly.   

 

 
 

Format is an extension of the style option: you can change the shape, size colouring and text 

style within the chart area as well as adding various effects.  You must be careful how you 

use this – too much unnecessary formatting can make a chart difficult to read (and therefore 

interpret).   

 

 
 

The Layout tab allows you to edit titles, legends, labels; to add axes and gridlines. Note: to 

get the best out of these you’ll generally need to enlarge the chart.  When doing so make sure 

you keep the chart ratios constant so the data representation doesn’t get distorted.  

If you want to make sure you get this right, simply move the chart to its own worksheet 

where it will be automatically enlarged in the correct ratios. 

 

Take note: A Pie chart fits onto any page layout whether Portrait or Landscape, whereas 

most other formats are best printed in Landscape view.  

To adjust gridlines choose the Format tab in Chart Tools then select 

your axis from the Chart Area menu in the Current Selection group.  

Then, click Format Selection. Under Axis Options click Fixed and 

then type a different number in the Major unit or Minor unit box. 

 

Note: Printing follows on the next page.  

  



15. Printing 
 

Before printing a worksheet, it is important to check how it looks. This can be done using the 

Print command under the File tab.   
 

File menu Print Options   Print Preview 
 

 
 

The Preview will indicate the number of pages at the bottom left-hand corner of the preview 

pane.  The orientation of the paper can be set to landscape or portrait.  

 

You should familiarise yourself with the various 

layout options, such as page fit and margins 

which can be accessed by clicking the Page 

Setup link which opens a dialog box.   
 

Tabs let you select printing options: 

 The default, Page option, allows you to select 

orientation, and adjust the fit of the worksheet 

so it will fit into a page.    

 The Margins option allows you to adjust the 

margins on the worksheet. 

 The Header/Footer option displays a window 

in which you can type a header and/or footer, 

which will be printed out on your spreadsheet.   

 Click the Custom Header or Custom Footer button to add text or select options like 

date/page numbering. 

 The Sheet option allows you to hide/display the gridlines or column and row headings, or 

change the order in which pages will be printed.   

Page Setup link 

(opens dialog box) 



You should spend some time exploring 

the possibilities for yourself. 

 

If a spreadsheet is too wide to fit across 

one sheet of A4 paper in Portrait 

orientation, the Landscape option can be 

selected.  The Scaling options under the 

Page tab of Page Setup can be used to 

decrease or increase the scale so that 

more or less data fits on a page.  

 

Page Break 

Sometimes scaling can’t give a good fit without compromising readability and you’ll need to 

print data over several pages. Note: if your data extends over several pages breaks will 

automatically be added.  This won’t always be where you’d prefer it however. 

 

In Page Break Preview (under the View tab) you can adjust page breaks to get a better 

division of the data. You can move a page break by dragging it with the mouse. 

 

 
 

You can even divide your worksheet up into smaller sections by inserting new page breaks.  

You do this by selecting the row or column below/right of where you want to insert the break 

then click Breaks in the Page Setup group, on the Page Layout tab. 

 

You should move breaks/insert breaks to create logical divisions within the worksheet.   

 

Page break (dotted line). 


